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Version information
This is a list of new features, enhancements and bug fixes which is updated with the release of 
each new version of Kith and Kin. Any last minute bug fixes are included here and may not be 
present in the flyers or readme files.

Tree (.TRE) and options (.OPT) files created with earlier versions of the program may require 
conversion before they can be used with this version. A data file conversion program (KKCONV) is
supplied with all registered versions of Kith and Kin.

Version 2.03    July 1994
Bug-fix release.
Kith and Kin was gradually eating up system resources, leading to insufficient memory after long 
sessions. This has been fixed.

The maximum number of generations for Descendant and Ancestral Tree prints has been 
increased to 80.

An overlap occurred in Descendant and Ancestral Tree prints where a person had an empty 
record. This has been fixed.

Print setup no longer changes the system default. Any changes are local to the current K&K 
session.

It is no longer possible to make the a single person appear more than once as a child of a single 
family. Similarly for marriages in Person Data.

You can now specify a Person or Family code in the Range|From field of a Person or Family Details 
print which does not exist. Kith and Kin will skip to the next valid code.

Getting Started and Other Products added to the Help menu.

Version 2.02    May 1994
ASP & Bug-fix release.
Registration reminders and Help file modified to meet ASP requirements.

Some characters were being lost around the edges of the Descendant and Ancestral Tree reports 
when printed on page (laser) printers. This has been fixed.

Printing of the Descendant and Ancestral Trees has been speeded up.

The shareware version caused an error when trying to display a registration reminder after the 
"Tree has changed..." message on exiting the program. This has been fixed.

"Search for help on..." command added to the Help menu.

Some modifications to the Help file, including user & distribution licences and warranty.

Version 2.01    February 1994
Bug-fix release.
The program crashed when printing Family Details for a family in which the father's surname had 
been entered but one or more of the children had no surname entered. This has been fixed.
Help file updated with USA and Australia registration details.



Version 2.0    February 1994
Support for PAF GEDCOM files (the Genealogical Data Communication standard) is now included. 
You can export and import data to and from other genealogy programs. Simply specify that the 
file you wish to open is a GEDCOM file and Kith and Kin will do the rest. You can create a new tree
or merge the GEDCOM file with an existing tree. Saving to a GEDCOM file is just as easy. Export 
one person, selected families or an entire tree.
There are now indicators in Person and Family data dialogs to show if any notes or objects are 
present.
The dialog fields and controls now have hot-keys to speed up keyboard use.
A new search facility has been added to check for people in limbo, ie. people who do not appear 
in families because they have no parents or marriages.
Due to the length of time taken to load larger GEDCOM files, a status indicator bar is displayed 
each time any file type is opened or saved. Clicking on the Cancel button will abort the process.
The placement of new family rectangles has been improved.
The Select Dialog has been improved to handle larger trees.
You can now scroll the tree area while moving or placing families. Simply move the cursor to the 
edge of window in the direction that you want to scroll. Hold down the CTRL key to move in larger
jumps. You can also use the PageUp, PageDn, Tab, Home and cursor keys to scroll around the tree
area.
The tree area display has been enhanced.
The current tree is not deleted when a File|Open fails.
Some reports were becoming garbled when text was being printed beyond the edges of the page 
(eg. in ancestral trees). This version correctly clips all text at the set margins.
The heading lines in the Family Details printout were missing from page 2 onwards on some 
printers. This has now been fixed.
A Person Details printout is now available for printing details of one or more people.
The Descendant and Ancestral trees now have titles and have been improved to handle multi-
page printing. Printers which can handle continuous stationery can produce large charts without 
having to join sheets.
The Ancestral Tree print did not include the surnames for people along the top of the report when 
printed without Child Surnames and Generations was > 0. This has been fixed.
The Family Details printout now has improved widow/orphan control, eg. a page break was 
possible between the CHILDREN header and the first child.
The Tree Layout print has been enhanced.
The Index printout can now be sorted by either code or name.
Appropriate menu items are now correctly disabled when there are no people and/or families in 
the current tree.
A full path-name can now be used to associate KITHKIN.EXE with .TRE files in the File Manager.
The following are the limits on the size of the tree data. You can have up to 16383 people and 
families combined. The size of the Tree Area is approx. 200 families wide by 350 high. The 
maximum number of characters which can be held in each person or family notes is 9500. 
Ultimately the total amount of tree data will depend on the amount of memory (RAM) in your PC. 
To some extent the speed of your PC will govern the usability of the software with large amounts 
of data.



SpanSoft is a member of the Association of Shareware Professionals (ASP). ASP wants to make 
sure that the shareware principle works for you. If you are unable to resolve a shareware-related 
problem with an ASP member by contacting the member directly, ASP may be able to help. The 
ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does not 
provide technical support for members' products.

Please write to the ASP Ombudsman at 545 Grover Road, Muskegon, MI 49442-9427 USA, FAX 
616-788-2765 or send a CompuServe message via CompuServe Mail to ASP Ombudsman 
70007,3536.



Getting started
This help topic is displayed automatically the first time you start Kith and Kin. To come back to 
this topic in future sessions use Help|Getting started from the main menu.

This help file is a complete on-line manual for Kith and Kin. As well as providing context-
sensitive help direct from Kith and Kin, it contains all the technical information about the 
program and details on how to register in an easy-to-use format.

Help
If you are not familiar with using Windows help files, read the 'help on help' information. Do this
by clicking the left mouse button on 'Help' in the menu above and then on 'How to Use Help' in 
the pull-down menu.

You can get help by either selecting Help|Contents from the main menu or by pressing F1. You 
can also get specific help on whatever task you are carrying out by selecting the Help button in 
the current dialog.

Basics

Introducing Kith and Kin

Opening an existing tree

Creating a new tree



Introducing Kith and Kin
Kith and Kin is a software package for documenting and storing family trees which has been 
specially designed for the MS-Windows operating system. It features an easy to use graphical 
interface and powerful multi-level editing tools which makes it ideal for both large and small 
trees.

The program supports date and place of births, marriages and deaths as well as multiple 
marriages and aliases for each person. Pictures, diagrams, sounds, etc may be embedded in or 
linked to a person or family.

A printed book can be produced with family group details (which may incorporate pictures and 
diagrams) and a complete, cross-referenced index to names and families. You have control over 
the formatting and extent of all printed reports which also include person details, tree layout, 
descendant and ancestral trees.

Compatibility with "Personal Ancestral File" GEDCOM files means you can export and import data 
to and from other genealogy programs. You can also use this feature to prepare extracts from 
tree files.

The information which you enter into Kith and Kin is organised into families. The main screen is a 
window into a tree area which displays each family as a rectangle. Relationships between families
are shown by parent lines. Using the mouse, you can drag and position the family rectangles 
within the tree area to form a standard tree layout. You can print out an image of the entire tree 
area to help you arrange the families in the best positions, using the Tree Layout print.

Once the tree has been built up, the family rectangles can be used for direct access to data by 
double-clicking the left mouse button on the required family. You can then traverse the tree by 
selecting people and families from within the family and person data. This makes it very easy to 
follow a particular route through the tree whilst examining, updating or even adding data.



Opening an existing tree
A sample tree file has been provided which demonstrates a typical family tree. This file is named 
SAMPLE.TRE and it should reside in the same directory as Kith and Kin (KITHKIN.EXE).

To open this tree select Open from the File menu. You will now see a file selection dialog. There 
are three different ways in which you can select SAMPLE.TRE as follows.
1) You can type in SAMPLE.TRE in the Filename field and press the <ENTER> key or click on 

the OK button.
2) You can click on SAMPLE.TRE in the Files list with the left mouse button and then click on 

the OK button or press the <ENTER> key.
3) You can double-click the left mouse button on SAMPLE.TRE in the Files list.
If SAMPLE.TRE does not appear in the Files list, it may not have been copied from your release 
disk into the Kith and Kin directory.

The sample tree file will then be opened and displayed on your screen.

Experiment with the PageUp, PageDown, Tab, arrow keys and the Home key which all move the 
main window to a new part of the tree area. See Keyboard for explanations of what each key 
does.

Try dragging a family rectangle to a new position by putting the cursor arrow over any family 
rectangle and then pressing and holding the left mouse button. You will see the cursor change to

 indicating that you can now reposition the family rectangle. While still holding the mouse 
button down, move the mouse and you will see a rectangular outline move about the screen. 
When you have moved this outline to the desired position, release the mouse button. The family 
rectangle will now move to the new position. You can also drag more than one family at a time by
following the same procedure but with the Shift key held down each time you click on a family 
rectangle.

You can display a summary of a particular family by putting the cursor arrow over the family 
rectangle and then holding down the right mouse button.

To examine or modify a particular family's data, you can double-click the left mouse button on a 
family rectangle. This will open a Family Data dialog which will allow you to edit this family's data.

Sample objects (a Paintbrush Picture and a Sound) have been embedded in family [F147]. Open 
the object list by selecting the Objects button in the Family Data dialog. You can then examine 
the map by double clicking the left mouse button on it or selecting the map in the list and then 
selecting "Edit Paintbrush Picture Object" from the menu (by clicking on the minus sign in the top 
left of the dialog). If you have a sound card in your PC (or a driver which lets you play .WAV files 
through the PC's speaker), you can play the sound by double clicking on the microphone icon or 
go via the menu as for the map. If an error occurs, it may be that Windows Paintbrush or the 
Sound Recorder has not been set-up correctly on your computer.

You can examine or edit the data associated with the parents and children of this family by 
selecting the appropriate edit button for parents or double-clicking on a child in the Children list. 
This will open a Person Data dialog which will allow you to edit this person's data.



Creating a new tree
When you first start Kith and Kin you will be presented with a blank tree area. If you have been 
looking at SAMPLE.TRE select New from the File menu to clear the tree.

Create your first family by selecting Add new family from the Edit menu or press Ctrl+F6. This will
bring up a family data dialog in which you may enter the details for this family. The only fields 
which may be entered directly in this particular dialog are the marriage details of the parents. Do 
this first if you are going to use them (remember all text edit fields are optional).

Next add the father by selecting the father add button (this action both adds a new person to the 
tree and identifies him as the father of this family).

This will bring up a person data dialog in which you may enter the details for the father. To add 
the family of which the father is a child select the child of family add button. This will again bring 
up a family data dialog and details may be entered as above.

Multiple dialogs may be opened like this up to a maximum of six. Exit each dialog in turn by 
selecting the Ok or Cancel button.

When all family data and person data dialogs have been closed any new families must be placed 
on the tree area. This is indicated by the cursor changing to . Move the cursor to the required 
position and click the left mouse button. All new families will be displayed as family rectangles. 
Note that whenever the cursor is this "inwards arrows" shape, you must click the left mouse 
button to place the families before you can do anything else. Don't worry if the families are 
placed in the wrong position, you can always move them afterwards.

Save your new family tree by selecting Save as from the file menu.



Edit menu
Either From the menu bar select Edit.
or Press Alt+E.

Menu items
Add new family
Add new person
Edit person
Edit family
Delete person
Delete family
Person notes
Family notes
Person objects
Family objects



Options menu
Either From the menu bar select Options.
or Press Alt+O.

Menu items
Startup file
Startup family
Page setup
Fonts
Preferences



Search menu
Either From the menu bar select Search.
or Press Alt+S.

Menu items
Text search
People in limbo
Go to family



File menu
Either From the menu bar select File.
or Press Alt+F.

Menu items
New
Open
Save
Save as
Print

Family details
Person details
Index
Tree layout
Descendant tree
Ancestral tree

Print setup
Exit



Add a family
Either From the Edit menu select Add new family.
or Press Ctrl+F6.
or New families are also added as a result of selecting the add button of a Marriage or a 

Child of Family in a Person Data Dialog.

Any of these actions will bring up a Family Data Dialog.
Following the addition of a new family the cursor will change to . This indicates that the new 
family rectangle(s) must be placed on the tree area. Move the cursor to the desired position and 
click the left mouse button to place the families.

If you want to place the new family on part of the tree area which is not currently visible, move 
the cursor to the edge of the window in the direction in which you want to move (eg. if you want 
to place the family to the right of the currently displayed area, move the cursor up against the 
right hand edge of the window). The window will scroll in small increments. You can scroll the 
window in larger increments by holding down the CTRL key.
You can also scroll the window using the PageUp, PageDn, Tab, Home and cursor keys.

See also: Database limits



Add a person
Either From the Edit menu select Add new person.
or Press Ctrl+F5.
or New people are also added as a result of selecting the add button of a Child, Father or 

Mother in a Family Data Dialog.

Any of these actions will bring up a Person Data Dialog.

See also: Database limits



Edit a family
Either From the Edit menu select Edit family. If a single family is currently highlighted then that

family will be selected for editing otherwise a Select Dialog will be displayed.
or Press F6. If a single family is currently highlighted then that family will be selected for 

editing otherwise a Select Dialog will be displayed.
or Double-click the left mouse button on a family rectangle.
or Select the edit button of a Marriage or a Child of Family in a Person Data Dialog.
or Double-click the left mouse button on a Marriage in a Person Data Dialog.

Any of these actions will bring up a Family Data Dialog.



Edit a person
Either From the Edit menu select Add person. A Select Dialog will be displayed.
or Press F5. A Select Dialog will be displayed.
or Select the edit button of a Child, Father or Mother in a Family Data Dialog.
or Double-click the left mouse button on a Child in a Family Data Dialog.

Any of these actions will bring up a Person Data Dialog.



Delete a person
From the Edit menu select Delete person.

This will bring up a Select Dialog with which to select the person to be deleted. Selecting Ok will 
immediately and irrevocably delete the person from the tree.



Delete a family
From the Edit menu select Delete family.

If a single family is currently highlighted then that family will be immediately deleted otherwise a 
Select Dialog will be displayed. Selecting Ok will immediately and irrevocably delete the family 
from the tree.



Adding and editing a person's notes
Either From the Edit menu select Person notes. This will bring up a Select Dialog from which to 

select the appropriate person.
or Press Shift+F5. This will bring up a Select Dialog from which to select the appropriate 

person.
or Select the notes button in a Person Data Dialog.

A Notes Dialog will then open in which to edit the notes.



Adding and editing a family's notes
Either From the Edit menu select Family notes. If a single family is currently highlighted then 

the notes associated with that family will be selected for editing otherwise a Select Dialog
will be displayed.

or Press Shift+F6. If a single family is currently highlighted then the notes associated with 
that family will be selected for editing otherwise a Select Dialog will be displayed.

or Select the notes button in a Family Data Dialog.

A Notes Dialog will then open in which to edit the notes.



Editing notes
Notes may be edited in a similar manner to the Windows Notepad editor.

The standard edit functions Undo, Cut, Copy and Paste are provided in the dialog's system menu 
(click on the minus sign in the top left of the dialog box).

Use the Find button to search for a piece of text in the notes. If you want upper and lower case 
letters to match exactly, set Case Sensitive. Once a piece of text has been found you can search 
for further occurrences of the same piece of text by selecting the Find Next button.

To search for and replace a piece of text with new text, use the Replace button. Set Replace All to 
replace every occurrence of the search text.

Lines will break automatically at the right hand edge of the notes dialog and at the right hand 
margin of printed reports so you should only enter a hard return <ENTER> at the end of 
paragraphs.

See also: Database limits



Adding and editing a person's objects
Either From the Edit menu select Person objects. This will bring up a Select Dialog from which 

to select the appropriate person.
or Press Alt+F5. This will bring up a Select Dialog from which to select the appropriate 

person.
or Select the objects button in a Person Data Dialog.

An Objects Dialog will then open in which to edit the objects.



Adding and editing a family's objects
Either From the Edit menu select Family objects. If a single family is currently highlighted then 

the objects associated with that family will be selected for editing otherwise a Select 
Dialog will be displayed.

or Press Shift+F6. If a single family is currently highlighted then the objects associated with
that family will be selected for editing otherwise a Select Dialog will be displayed.

or Select the objects button in a Family Data Dialog.

An Objects Dialog will then open in which to edit the objects.



Working with objects
You may link or embed one or more objects in each person or family. The objects may be created,
played, edited, deleted, copied to the clipboard or printed as part of a Family Details or Person 
Details document.

Using the Paste Link, Paste or Insert commands will insert a new object into the objects list. The 
object will be inserted before the currently selected object or added to the end of the list if there 
is no current selection.

Linking objects
Start the application which contains the object to be linked. Select the object and copy it to the 
clipboard using the COPY command. Switch to Kith and Kin and open the Objects Dialog which is 
going to receive the object. Select the Paste link command in the dialog's system menu (click on 
the minus sign in the top left of the dialog box). The object will be inserted into the objects list. If 
the Paste link command is not available it probably means that the object's source document has 
not been saved.

Embedding objects
Start the application which contains the object to be embedded. Select the object and copy it to 
the clipboard using the Copy command. Switch to Kith and Kin and open the Objects Dialog which
is going to receive the object. Select the Paste command in the dialog's system menu (click on 
the minus sign in the top left of the dialog box). The object will be inserted into the objects list.

Creating new objects
Objects may be embedded by starting the source application within Kith and Kin.
To do this select the insert button. Select an object from the available object types in the Insert 
Object Dialog. The associated application will start and you may create an object within it. When 
you exit the source application the object will appear in the objects list.

Editing and playing objects
The Object command in the dialog's system menu (click on the minus sign in the top left of the 
dialog box) will be different for each object type. Select the object command appropriate to the 
action which you wish to carry out. The commands invariably include Edit and sometimes 
additional commands such as Play (eg. for sound objects) are available.
Double-clicking the left mouse button on an object will perform the default action for that 
particular object type. Normally this is Edit but it will vary depending on the object type (eg. Play 
for sound objects).

Copying objects
Select an object from the objects list. Select the Copy command in the dialog's system menu 
(click on the minus sign in the top left of the dialog box). This will copy the object to the clipboard
from which it may be pasted to another objects list or a different application. If you want to 
delete the object from the list at the same time, use the Cut command instead of Copy.

Deleting objects
Existing objects may be deleted from the objects list by selecting the object delete button.

Each object in the objects list has the following attributes.

Description
A short description of the object, initially set to the object type.



Print object with notes
When set, the object is printed full-size (within the defined margins) along with any notes 
belonging to the appropriate person or family in the Family Details or Person Details document.

See also: Known incompatibilities



Insert Object Dialog
The list includes all types of OLE object which exist on your system. Select the object to insert 
into the objects list and select the OK button or double-click the left mouse button on an item.
The appropriate application will start to allow you to edit the object which has now been added to
the object list. Note that an object created from this dialog is always embedded into the tree.



New file
From the File menu select New.

This will first check to see if the current tree needs to be saved and then clear the tree.



File selection dialog
The file selection dialog is displayed in response to a File|Open, File|SaveAs or Options|StartupFile
command.

Open or Startup
Select the type of file to open or save, Kith and Kin tree or GEDCOM. If necessary select the 
appropriate directory by double-clicking on a directory entry. Select the required file from the 
available files list. In the case of a GEDCOM File|Open, a GEDCOM import dialog will open.

Save as
Select the type of file to open or save, Kith and Kin tree or GEDCOM. If necessary select the 
appropriate directory by double-clicking on a directory entry. Enter the required file name and 
select the Ok button. In the case of a GEDCOM File|SaveAs, a GEDCOM export dialog will open.



Open file
From the File menu select Open.

This will first check to see if the current tree needs to be saved and then bring up a file selection 
dialog.

Use File|Open for loading Kith and Kin tree files (.TRE) and importing GEDCOM files (.GED).



Save file
Either From the File menu select Save.
or Press F2.

The tree will be saved with the name of the file shown in the main window title. If the tree has no 
current filename the tree will not be saved and Save As should be used instead.



Save as file
From the File menu select Save as.

This will bring up a file selection dialog.

Use File|SaveAs for saving Kith and Kin tree files (.TRE) and exporting GEDCOM files (.GED). If you
save a Kith and Kin tree file with File|SaveAs, the name of the current tree will be changed to the 
saved filename.



Exit
Either From the File menu select Exit.
or Press Alt+F4.

This command will check to see if the current tree needs to be saved before exiting the program.



Keyboard / Mouse key assignments
Keyboard
F1 Help Open the Kith and Kin help file at the contents topic
Ctrl+F1 Help search Search for keywords in the Kith and Kin help file
F2 Save Save the current tree (not available for untitled trees)
Alt+F4 Exit Exit Kith and Kin

F5 Edit person Edit an existing person's data
Ctrl+F5 Add person Add a new person to the tree
Shift+F5 Person notes Add or edit a person's notes
Alt+F5 Person objects Add or edit a person's objects

F6 Edit family Edit an existing family's data
Ctrl+F6 Add family Add a new family to the tree
Shift+F6 Family notes Add or edit a family's notes
Alt+F6 Family objects Add or edit a family's objects

F8 Text search Search for a piece of text
F9 Go to family Scroll the tree area to a specific family

PageUp Scroll page up Moves the tree area window up one page
PageDn Scroll page down Moves the tree area window down one page
Tab Scroll page right Moves the tree area window right one page
Shift+Tab Scroll page left Moves the tree area window left one page
Home Scroll to Startup family (if any)
Left, right Scroll left or right
Up, down Scroll up or down

Mouse (tree area control)
Left Select family Select a family (hold to drag to new position)
Double Left Edit family Edit a family's data
Shift+Left Select families Select more than one family
Ctrl+Left Scroll page Moves tree area in large jumps when dragging families

Right Family summary Displays details of the family under the cursor



The tree area is the area in which the family tree appears. A selected part of this area is 
displayed in the program's main window and the window may be moved around the tree area to 
view different parts of the tree. The tree area contains a family rectangle for every family and 
these may be positioned to provide the best layout. The tree area may be printed using the print 
tree command.



A marriage is a family unit of which the current person is a parent. A person may have no 
marriages or a list of marriages. The resulting families may or may not have any children.



A child of family identifies the family unit of which the current person is a child. A person may 
or may not be the child of a family.



A child is a person who appears in the list of children of the current family.



A mother is a person who is identified as the mother of the current family.



A father is a person who is identified as the father of the current family.



An alias is an alternative name for a person along with the date on which the alias was adopted. 
Characters are converted to uppercase for the surname. Aliases are useful, for example, where a 
person was commonly known by a name which was not their name at birth. You can use the alias 
to look up the person in an printed index or selection dialog.



An object is a piece of information (typically a drawing, picture, slide, sound etc) which has been 
created by a separate application and which has been embedded in or linked to a person or 
family. You can use an object from any application which supports OLE (Object Linking and 
Embedding).



Linking an object to a person or family involves copying your selected object from another 
application onto the clipboard and then pasting the link into the person's or family's objects list. 
The primary difference between linking and embedding is the location of the actual data for the 
object. The data for a linked object is stored outside the tree file in a separate source document, 
eg. a .BMP file for Paintbrush.



Embedding an object in a person or family involves copying your selected object from another 
application onto the clipboard and then pasting it into the person's or family's objects list or 
creating a new object directly. The primary difference between embedding and linking is the 
location of the actual data for the object. The data for an embedded object is stored inside the 
tree file. 



Dialog buttons
Click on a button for its definition.
Person and/or family data dialogs

 
 

 
 

 

Alias dialog

 
 

Objects Dialog

 

Miscellaneous



An identify button is one of several buttons in Person and Family Data Dialogs which identify an
existing family or person and link it to the current person or family as a child of family, marriage, 
father, mother or child depending on which button is selected.



An add button is one of several buttons in Person and Family Data Dialogs which both create a 
new family or person and link it to the current person or family as a child of family, marriage, 
father, mother or child depending on which button is selected.



An edit button is one of several buttons in Person and Family Data Dialogs which edit a family or
person which is identified as a child of family, marriage, father, mother or child depending on 
which button is selected.



 
A remove button is one of several buttons in Person and Family Data Dialogs which remove the 
link to a family or person which is identified as a child of family, marriage, father, mother or child 
depending on which button is selected. You are given the option of deleting the family or person 
from the tree at the same time.



The highlight off button cancels any selection made in either a child or marriage list. This 
allows new items to be identified or added at the end of the list instead of prior to the highlighted
item.



The add button will add the entered data to the person's list of aliases.



The edit button will retrieve the selected alias to allow editing.



The delete button will remove the selected alias from the person's list of aliases.



The alias button allows the addition and editing of the current person's aliases. Only available 
from a Person Data Dialog.



The notes button opens a Notes Dialog in which to edit a person's or family's notes.



The objects button opens an Objects Dialog in which to edit a person's or family's objects.



The close button exits from various dialogs. Any data in the dialog has already been accepted 
and selecting close will neither update nor reject it.



The insert object button creates a new embedded object from within Kith and Kin and inserts it
into the objects list.



The delete object button deletes the currently selected object from the objects list.



The OK button accepts the data currently displayed in the dialog and closes it.



The cancel button ignores the data currently displayed in the dialog and closes it.



The help button opens the on-line help file at a topic relevant to the current dialog.



 or 
The contents indicator tells you whether there are any entries present within the associated 
button, ie. the Notes or Objects buttons.



A family rectangle is a shape similar to this which is used for selecting a particular family. F147 
is the family code, GORDON is the surname of the father and SCOTLAND is the surname of the 
mother. The blue ( ) and pink (
) icons denote male and female members of the family respectively, the two people along the 

top edge are the parents, the seven along the bottom edge are the children. Parent Lines 
emanate from appropriate people indicating links to other families. You can display a summary of 
a family by holding down the right mouse button on it. One or more family rectangles may be 
moved around on the tree area by highlighting and then dragging.



One or more families may be selected by highlighting them as shown here. To highlight a single 
family rectangle click the left mouse button on it. To highlight several family rectangles at once 
hold down the Shift key while clicking the left mouse button on each family rectangle in turn. 
Highlighted family rectangles may be moved around the tree area by dragging the outlines to a 
new position. If you want to scroll the tree area window while repositioning families, move the 
cursor right up to the edge of the window. The window will scroll in small increments and you can 
scroll in larger jumps by holding down the Ctrl key.



Parent Lines denote the relationships between families. Shown here are (a) the father of family 
F146, (b) the mother of family F146 and (c) the father of family F118 who is also the first child of 
family F146. When moving family rectangles around the tree area, parent lines will follow like 
rubber-bands.



Person data 
The Person Data Dialog allows the addition, editing and display of a specific person's data.
Click the left mouse button on the item of interest below to get a definition.



Person Data - Code
The code is the letter 'P' followed by a number which uniquely identifies a particular person. The 
code is assigned automatically and is not necessarily the next in sequence.



Person Data - Surname
The surname of the person (normally the surname at birth). Characters are converted to 
uppercase.



Person Data - Firstnames
The first or christian names of the person.



Person Data - Alias
Selecting the alias button will bring up the Alias Dialog.
If the appropriate preference is set, an alias will be automatically added to the mother of a family 
comprising her married surname, her firstnames and the date of marriage. This alias will not be 
removed automatically in the event of a mother's deselection.



Person Data - Gender
A gender (male or female) must be supplied for the person. Only males may become fathers and 
females mothers.



Person Data - Birth
The date and place of birth of this person. The date is not validated and may be entered in any 
form.



Person Data - Death
The date and place of death of this person. The date is not validated and may be entered in any 
form.



Person Data - Child of Family
A family identified as the family of which this person is a child. The names and marriage details of
the parents are displayed and may be scrolled by clicking the cursor in the display field and using
the left and right arrow keys.
A family may be identified as a child of family if it already exists in the tree by selecting the 
child of family identify button.
A family which does not yet exist in the tree may be added by selecting the child of family add 
button. This will bring up a Family Data Dialog.
If a child of family exists for this person, its Family Data may be edited or displayed by 
selecting the child of family edit button.
If a child of family exists for this person, it may be deselected by selecting the child of family 
remove button. The option of deleting the family from the tree is given at this time.



Person Data - Marriages
A list of families identified as having resulted from marriages of this person. The names and 
marriage details of each families parents are displayed.
A family may be identified as a marriage of this person if it already exists in the tree by 
selecting the marriage identify button. The new marriage is inserted into the list before the 
currently selected marriage (or at the end if none is selected).
A marriage which does not yet exist in the tree may be added by selecting the marriage add 
button. The new marriage is inserted into the list before the currently selected marriage (or at the
end if none is selected). This will bring up a Family Data Dialog.
The Family Data of marriages in the list may be edited or displayed by first selecting the 
family's name and then selecting the marriage edit button or by double-clicking the left mouse 
button on the family's name.
Families may be deselected as resulting from a marriage of this person by first selecting the 
family's name and then selecting the marriage remove button. The option of deleting it from the
tree is given at this time.
To identify or add a marriage to the end of the list it is necessary to have no marriages selected 
from the list. The marriage highlight off button is provided to achieve this.



Family data
The Family Data Dialog allows the addition, editing and display of a specific family's data.
Click the left mouse button on the item of interest below to get a definition.



Family Data - Code
The code is the letter 'F' followed by a number which uniquely identifies a particular family. The 
code is assigned automatically and is not necessarily the next in sequence.



Family Data - Father
A person identified as the father for this family. His name and birth details are displayed and may 
be scrolled by clicking the cursor in the display field and using the left and right arrow keys.
A person may be identified as father of this family if he already exists in the tree by selecting 
the father identify button.
A father who does not yet exist in the tree may be added by selecting the father add button. This
will bring up a Person Data Dialog.
If a father exists for this family, his Person Data may be edited or displayed by selecting the 
father edit button.
If a father exists for this family, he may be deselected as father of this family by selecting the 
father remove button. The option of deleting him from the tree is given at this time.



Family Data - Mother
A person identified as the mother for this family. Her name and birth details are displayed and 
may be scrolled by clicking the cursor in the display field and using the left and right arrow keys.
A person may be identified as mother of this family if she already exists in the tree by selecting 
the mother identify button. An alias may be generated automatically if the preference is set.
A mother who does not yet exist in the tree may be added by selecting the mother add button. 
An alias may be generated automatically if the preference is set. This will bring up a Person Data 
Dialog.
If a mother exists for this family, her Person Data may be edited or displayed by selecting the 
mother edit button.
If a mother exists for this family, she may be deselected as mother of this family by selecting 
the mother remove button. The option of deleting her from the tree is given at this time.



Family Data - Marriage
The date and place of marriage of the parents of this family unit. The date is not validated and 
may be entered in any form.



Family Data - Children
A list of people identified as children of this family. Their names and birth details are displayed.
A person may be identified as a child of this family if (s)he already exists in the tree by selecting
the child identify button. The new child is inserted into the list before the currently selected child 
(or at the end if none is selected).
A child who does not yet exist in the tree may be added by selecting the child add button. The 
new child is inserted into the list before the currently selected child (or at the end if none is 
selected). This will bring up a Person Data Dialog.
The Person Data of children in the list may be edited or displayed by first selecting the child's 
name and then selecting the child edit button or by double-clicking the left mouse button on the 
child's name.
Children may be deselected as belonging to this family by first selecting the child's name and 
then selecting the child remove button. The option of deleting him/her from the tree is given at 
this time.
To identify or add a child to the end of the list it is necessary to have no children selected from 
the list. The child highlight off button is provided to achieve this.



Alias Dialog
A person may have several aliases.
Aliases are added by entering the surname, firstnames and date of change then selecting the 
add button. The date is not validated and may be entered in any form.
Edit an alias by first selecting the alias from the list then selecting the edit button or by double-
clicking the left mouse button on the alias. This will copy the data into the edit boxes where it 
may be changed. Press return to put the alias back into the list.
An alias may be deleted by first selecting the alias from the list then selecting the delete button.



Select dialog
The select dialog is displayed in various circumstances when an action has been requested which
acts on a specific family or person, eg. deleting a person or printing descendants.

Selection may be done by either entering a code number (digits only, do not enter the P or F) or 
selecting from the list of families or people.



Startup file
From the Options menu select Startup file.

This will bring up the file selection dialog. You may select an existing file or enter a new file name.
The program will attempt to load the tree automatically each time the program is started unless 
the program is launched from a tree file in the File Manager (you have to associate .TRE files with 
KITHKIN.EXE to do this).



Startup family
From the Options menu select Startup family.

Selecting the Change button will bring up the Select Dialog. You may select any family in the 
current tree. The program will attempt to move the tree area window to that family automatically 
each time the current tree file is opened. If no family is selected the window will start in the upper
left corner of the tree area.

The tree area will be scrolled to this family each time the HOME key is pressed.



Preferences
From the Options menu select Preferences.

This will bring up the Preferences Dialog, one or more of the following options may be set.

Marriage produces wife's alias
When a person is identified as the mother of a family an alias is automatically generated 
comprising her married surname, her firstnames and the date of marriage. This alias will not be 
removed automatically in the event of a mother's deselection.

Display large objects
The image of a large object may take a while to draw into the objects list, depending on the 
speed of your PC. To overcome this problem you may display a simple grey rectangle in the list in 
place of the image of    large objects by turning this option off. Changing this option does not 
affect the contents of the object or the way it is printed.



Positioning the tree area window
Either From the Search menu select Go to family.
or Press F9.
or Use PageUp, PageDn, Tab, Home or the cursor keys.
or Use the scroll bars along the right and bottom edges of the window to move the window 

around the tree area.

Selecting Go to family or F9 will bring up a Select Dialog with which to select the family to move 
to. The tree area window will then display a new area of the tree with the selected family in the 
centre.

If you want to scroll the tree area window while repositioning or placing families, move the cursor 
right up to the edge of the window. The window will scroll in small increments and you can scroll 
in larger jumps by holding down the Ctrl key.



Search for text
Either From the Search menu select Text search.
or Press F8.

This will bring up the Search Dialog which will perform a search through the entire tree based on 
the selection of the following options. When the search is complete, a list of people and/or 
families is displayed. To edit a person or family from the list either double-click the left mouse 
button on the item or select first the item and then the edit button.

Search for
Enter the text which is to be searched for.

Case sensitive
If set, the search will find text which exactly matches the sequence of upper and lower case 
letters in the search text otherwise the case of both the search text and searched text is ignored.

The following fields specify which items in the tree are to be searched through. One or more may 
be set.
Family - Marriage
The date and place of marriage of a family's parents.
Family - Notes
The notes associated with a family.
Person - Name
A person's surname and firstnames.
Person - Aliases
All of a person's alias details in each of their aliases, ie surname, firstnames and date of change.
Person - Birth
The date and place of birth of a person.
Person - Death
The date and place of death of a person.
Person - Notes
The notes associated with a person.



Search for people in limbo
From the Search menu select People in limbo.

The program will search the tree for all people who are neither parents nor children in any family 
and therefor cannot be accessed via the family rectangles in the tree area.

When the search is complete, a list of people is displayed. To edit a person from the list either 
double-click the left mouse button on the item or select first the item and then the edit button.



Print family details
From the File menu select Print then from the sub menu select Family details.

This will bring up the Print Family Details Dialog which will print one or more family group sheets 
based on the selection of the following options. The fonts used will be those previously selected 
using the Fonts Dialog.

All / Selection / Range
Only one of these options may be selected. All prints every family, Selection prints all families 
which are currently highlighted, Range prints all families which fall inside the range of code 
numbers specified in From and To.

The following fields specify what details to include in the printout. One or more may be set.
Include person codes
A person code will be printed beside the name of each person.
Include aliases
Aliases will be included in places where a person's details are being printed.
Details everywhere
A person's details will be printed wherever that person's name appears. If not set then the details
are only printed where the person appears as a child or, if the person has no child of family, then 
wherever the person's name appears.



Print person details
From the File menu select Print then from the sub menu select Person details.

This will bring up the Print Person Details Dialog which will print one or more person's details 
based on the selection of the following options. The fonts used will be those previously selected 
using the Fonts Dialog.

All / Selection / Range
Only one of these options may be selected. All prints every person, Selection brings up a 
Selection Dialog with which you may select a single person to print, Range prints all people 
which fall inside the range of code numbers specified in From and To.

The following fields specify what details to include in the printout. One or more may be set.
Include person codes
A person code will be printed beside the name of each person.
Include aliases
Aliases will be included for the selected person(s).



Print index
From the File menu select Print then from the sub menu select Index.

This will bring up the Print Index Dialog which will print a family and/or person index for the 
current tree based on the selection of the following options. The fonts used will be those 
previously selected using the Fonts Dialog.

Sort
Select either By name or By code. "By name" produces an alphabetic index sorted on the 
surname and firstnames of each person or father of a family. A "By Code" index is sorted on the 
code of each person or family.

Family index
If set then an index to families will be printed.

The following fields specify what details to include in the family index. One or more may be set.
Person codes
A person code will be printed beside the name of each person.

Marriage details
The date and place of marriage will be included.

Person index
If set then an index to people will be printed.

The following fields specify what details to include in the person index. One or more may be set.
Person codes
A person code will be printed beside the name of each person.
Birth details
The date and place of birth will be included.
Death details
The date and place of death will be included.
Aliases
Index entries will be generated for each alias of a person.



Print tree layout
From the File menu select Print then from the sub menu select Tree layout.

This will bring up the Print Tree Dialog which will print the entire tree area based on the selection 
of the following options. The fonts used will be those previously selected using the Fonts Dialog.

Family code
If set then the family code will be printed in each rectangle.

Marriage details
If set then the marriage date and place will be printed in each rectangle.

Label format
Only one of the following options may be selected to indicate the format of each rectangle label.
Father's surname
Only the father's surname will be printed.
Father's and mother's surname
Father's and mother's surname will be printed.
Father's and mother's full names
The full names of both father and mother will be printed.

Text line spacing
Enter a decimal number to indicate any deviation from the standard line spacing eg:
1 = use standard line spacing,
0.5 = reduce the line spacing to half of standard,
2 = increase line spacing to double spaced.

These options are designed to make the tree printout as clear as possible. The entire tree will 
always be scaled to fit into a single page so that a large tree will have the smallest family 
rectangles and will require a minimal amount of text.



Options for descendant & ancestral tree prints
The printout may include one or more of the following:
Codes
Person and family codes are printed beside the name of the person or family.
Child surnames
The surname for every child is included. If not set, the surnames can still be determined from the 
surname of the father of each family.
Birth date / Death date / Marriage date
These details may also be included.

The following options may also be set:
Wrap surnames
In order to save horizontal space, the surnames may be printed below the firstnames of each 
person by setting this option.
Inside margins
Trees which are too large to fit on a single page will be split onto multiple pages. When this option
is set, each page will have margins as defined in page setup. When this option is not set, margins
which would be along the "joins" of the printout will be set to zero. This is particularly useful when
printing a large tree landscape on continuous paper. If you find that data is missing from the 
edges of your printout, particularly on page (laser) printers, try setting Inside Margins and 
increasing the margin values until all the data is visible. A degree of overlapping text is printed to
make it easier to paste together adjoining sheets.
Expand to ? generations
If this figure is 0, the printout will include every descendant or ancestor of the selected person. 
However, large trees may produce printouts which are impossible to fit onto a single page. You 
may limit how many generations the report will cover by changing this entry. For example, 2 
generations of descendants will produce the selected person, his children and his grandchildren.



Print descendant tree
From the File menu select Print then from the sub menu select Descendant tree.

This will bring up a Select Dialog with which to select the person to base the printout on. The 
printout will be based on the options selected from the Print Descendants Dialog and the fonts 
used will be those specified in the Fonts Dialog.

This printout will consist of a tree with the selected person at the top and all of his directly related
(blood) descendants and spouses below. The tree tends to be wide rather than long so use a 
small font and print landscaped.



Print ancestral tree
From the File menu select Print then from the sub menu select Ancestral tree.

This will bring up a Select Dialog with which to select the person to base the printout on. The 
printout will be based on the options selected from the Print Ancestors Dialog and the fonts used 
will be those specified in the Fonts Dialog.

This printout will consist of a tree with the selected person at the bottom and all of his directly 
related (blood) ancestors above. The tree tends to be wide rather than long so use a small font 
and print landscaped.



Print setup
From the File menu select Print setup.

This will display a list of available printers. Select the required printer and if you want to change 
the settings for that printer (paper size, orientation etc), select the setup button to open the 
printer driver's setup dialog.

See Windows or your printer driver documentation for further details of the setup dialog for 
particular printers.



Fonts
From the Options menu select Fonts.

This will bring up the Fonts Dialog from which the fonts for various features of all printed 
documents may be set.

Select a feature to change from one of the lists and a sample of the currently selected font will 
appear in the Sample Window. Selecting the Change button will bring up a standard font selection
dialog. You can then change the typeface, style, size, effects and colour of the font. Note that you
are not limited to using the listed font sizes.

Family & Person Details
Title
The surname of the family unit or person's name which appears at the top of the page.
Code
The code number which appears in the top right corner.
Headings
For family details the headings are "Parents", "Children" and "Family".
Names
The line containing the name of each parent and child.
Notes
The text of notes and details.

Index
Title
The title for each index is either "Index to People" or "Index to Families".
Text
The text of the index entries.

Tree Layout
Text
All the text on tree document will be printed using this font.

Descendant & Ancestral Trees
Names
The names of each person will be printed using this font..
Dates
Dates and all other information is printed in this font.

Revision footer
Text
In all printed documents a revision date is optionally printed at the bottom of each page. See 
Page Setup for details on how to modify the footer.



Page setup
From the Options menu select Page setup.

The page setup dialog allows you to format various features of the layout of all printed 
documents.

Margins
Enter the measurement for each of the page margins. The unit of measure may be either inches 
or millimetres. Note that problems with printouts may be encountered when setting small 
margins. The printer you are using may have a non-printing area around the edge of the physical 
page and this may lead to missing or garbled print. If you have problems like this, try increasing 
the size of the margins.

Revision Footer
Set Include to print a revision date footer on every page of each printed document. It is useful to 
have the current date printed on each report, particularly when the tree data is constantly being 
updated and only updated sections are being reprinted. The footer is printed just below the 
bottom margin and takes the following format: <document> <text> <date>

<document> is dependant on the type of document being printed, eg. "Tree", "Index", etc.
<text> is user defined text which may be entered in the Text field.
<date> is the current date and may be formatted in one of styles shown in the dialog with an
optional separator character between day, month and year (note that this date format has no 
effect on dates entered in person or family details).

eg. On the Family Details document for family F56, the current date is 5th September 1992 
formatted DD/MM/YYYY with a "-" separator and the text field is "Revision:", the following footer is
printed: "[F56] Revision: 5-9-1992"



Import GEDCOM file
From the File menu select Open then select GEDCOM from the file type list in the file selection 
dialog.

When you have selected the required file and the Ok button, you will be given the choice of 
various options for importing a GEDCOM file, as follows.

Create new tree
The current tree (if any) will be closed and the imported data will form the basis of a new tree, 
untitled.

Import into current tree
The current tree (if any) is retained and the imported data is added to it.

Store extra data in notes
"Extra data", is GEDCOM data which Kith and Kin recognises, but has no specific field for. By 
setting this option any extra data will be added to the appropriate set of notes. See Supported 
GEDCOM data for a list of recognised extra data.

List extra data in GEDERR.TXT
By setting this option any extra data will be added to the GEDCOM import error log, GEDERR.TXT.

Display file header and submitter.
The GEDCOM file header and any submitter information will be displayed as it is read from the 
file.

If the program encounters the end of a GEDCOM file before finding the TRLR record, it assumes 
that the file has been split over more than one disk (or file). You will be prompted to insert the 
disk containing the next file in sequence. GEDCOM files split into several files are named 
<filename>.GED, <filename>.G00, <filename>.G01, etc, where <filename>.GED is the filename
specified for input in the file selection dialog.

Errors encountered during a GEDCOM import are always reported in GEDERR.TXT and you can 
optionally open this file using NOTEPAD after the import.

See also: Known incompatibilities



Export GEDCOM file
From the File menu select Save as then select GEDCOM from the file type list in the file selection 
dialog.

When you have entered the filename and selected the Ok button, you will be given the choice of 
various options for exporting a GEDCOM file, as follows.

All families.
Set this option to export all people and families from the current tree.

Selected families.
Export only the currently highlighted families and the people who appear in them by setting this 
option.

One person.
A select dialog will open with which to select a single person for exporting.

Include objects.
If you want the GEDCOM file to include the objects associated with the people or families you are 
exporting, set this option. Objects exported in this way can only be imported by Kith and Kin V2.0
or later, and will produce a very large amount of output.

Submitter information.
If you want to include your name, address, phone number and any comments relevant to the 
particular GEDCOM file, enter them here. They will be output as part of the SUBM record. If all 
four fields are empty, no SUBM record will be output.

If the GEDCOM file becomes too big for the disk it is being written to, the program will prompt you
to insert another blank disk and will repeat this as necessary until the entire file has been written.
Subsequent files will be named <filename>.G00, <filename>.G01, etc, where <filename>.GED is
the filename specified for output in the file selection dialog.

Note that the GEDCOM file will contain data which is specific to Kith and Kin. Other programs will 
ignore this data on import but may report it in an error file. Do not be surprised to find a large 
amount of reported exceptions, it should not affect the import of data.



Supported GEDCOM data
Kith and Kin supports the PAF (Personal Ancestral File) variation of the GEDCOM (Genealogical 
Data Communication) standard, as used by the majority of genealogical programs. There are 
some quirks in PAF GEDCOM, which make it different from the GEDCOM standard proper, and so 
there are no guarantees that Kith and Kin will correctly read GEDCOM files not designed to be 
read by PAF.

Fully supported tags: (have corresponding fields in Kith and Kin)

Record Tag Description
HEAD File header.

SOUR Source system.
DEST Destination system (PAF).
DATE Date of file.
NAME Name of file.
CHAR Character set. Kith and Kin assumes IBMPC unless a valid CHAR tag is 

found. IBMPC, MACINTOSH and ANSEL sets are converted to ANSI for 
use in Windows. Kith and Kin always exports in ANSI.

_SFAM (Kith and Kin GEDCOM files only).
SCHEMA Kith and Kin ignores this tag on import, but inserts a SCHEMA tag in 

exported files to define Kith and Kin specific tags.

SUBM File submitter.
NAME Submitter's name.
ADDR Submitter's address.
PHON Submitter's phone number.
COMM Comments.

INDI Person data (individual).
NAME Firstnames and surname. If there is more than one NAME tag for a 

particular person, the last one is regarded as the normal name and prior
ones are regarded as aliases.

SEX Gender, male or female (male is assumed if missing).
BIRT Date and place of birth.
DEAT Date and place of death.
NOTE Notes.
FAMS Family id of which this person is a parent.
FAMC Family id of which this person is a child.
_BLOB (Kith and Kin GEDCOM files only).
_OBJS (Kith and Kin GEDCOM files only).

FAM Family data.
HUSB Person id of the father of this family.
WIFE Person id of the mother of this family.
CHIL Person id of a child of this family.
MARR Date and place of marriage.
NOTE Notes.
_FBLOB (Kith and Kin GEDCOM files only).
_MBLOB (Kith and Kin GEDCOM files only).
_PCODE (Kith and Kin GEDCOM files only).
_PNAME (Kith and Kin GEDCOM files only).
_FRECT (Kith and Kin GEDCOM files only).
_OBJS (Kith and Kin GEDCOM files only).

Extra data tags: (are optionally inserted in notes)



Record Tag Description
INDI Person data (individual).

REFN Reference number.
TITL Title.
CHR Date and place of christening.
BURI Date and place of burial.
OCCU Occupation.
EDUC Education.
RELI Religion.
NATI Nationality.
CAST Caste.

FAM Family data.
REFN Reference number.
DIV Divorced.

Any other tags encountered in an imported GEDCOM file are ignored but are reported in the log 
file GEDERR.TXT.



How to contact us

By mail: Nick J Hunter
SpanSoft
11 Morlich Park
Dalgety Bay
DUNFERMLINE
Fife      KY11 5XW
Scotland

By telephone: National:                (0383) 824380
International:    +44 383 824380
(voice or fax)
(0900 - 1700 GMT/BST Monday - Friday)

By E-Mail: Internet: nick.hunter@almac.co.uk
FidoNet: NICK HUNTER (2:259/17)
CompuServe: 100101,1155

SpanSoft is a member of the ASP.



Registration
Kith and Kin is a shareware product. This version has been provided so that you may evaluate its 
features and suitability for a trial period of 30 days without payment. We hope that you enjoy 
using it and that you will find it of use. In the event that you wish to continue using it after 30 
days you must become a registered user.

The registration fee is £24. For this you will receive the latest registered version (without all the 
boring shareware reminders), a file conversion program which allows you to use your data files 
with the latest version, access to telephone support, periodic notification of future releases and 
discounts on upgrades. If you do not wish to continue using Kith and Kin after 30 days you must 
delete the program from your system.

See also: How to contact us and Terms of use.

There are various ways of becoming a registered user, depending on what country you live in and
how you want to pay.
Click on the method most convenient for you from the following choices.

You can register on-line if you are a CompuServe member.

Alternatively, select from the list below if you live in:

UK
USA
Australia
New Zealand

Rest of the World

Only with your financial support will I be able to provide you with upgrades and produce more 
quality software. Without your support I will not be able to do so.
The survival of this program and of the shareware concept in general depends on your honesty.



Registering in the UK
Select payment method:

Cheque / Postal order / Cash

Credit card (Visa / Access)



Registering in the USA
Select payment method:

UK funds (Pounds Sterling)

Credit card (Visa / MasterCard / Amex / Discover)



Registering in Australia
Select payment method:

UK funds (Pounds Sterling)

Cheque / Money order / Credit card (Visa / MasterCard)



Registering in New Zealand
Select payment method:

UK funds (Pounds Sterling)

Cheque / Money order / Credit card (Visa / MasterCard / Bankcard / 
Diners / Amex)



Registering in the rest of the World
Select the country closest to you from this list:
USA, Australia, New Zealand

or select payment method:

UK funds (Pounds Sterling)

Credit card (Visa / MasterCard)



Registering on-line via CompuServe
If you are a CompuServe (CIS) member, you can register and pay the registration fee using the 
CompuServe Shareware Registration Service.

The registration fee is $36 + $4 shipping to all parts of the world (US$). Payment will be charged 
to your CompuServe account.

Log-on to CompuServe in the normal way and at any ! prompt type GO SWREG. Kith and Kin's CIS
Registration ID is 2537. Please follow the instructions on-screen.

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk. If you require a different size please 
send an E-mail message to 100101,1155 stating your preferred media, at the same time as 
you register with SWREG.

Your registered copy of the latest version of Kith and Kin will be despatched air mail from 
SpanSoft within 2 working days of your request being entered onto CompuServe. Delivery is 
normally around 1 week to most parts of the world but please allow at least 2 weeks.
Prices correct at July 1994 for V2.03 but registration for later releases may be subject to price increases. Please check current price 
on CIS.



Order - Kith and Kin
Please print this order using Print Topic and mail to:
 SpanSoft

11 Morlich Park
Dalgety Bay
DUNFERMLINE
Fife      KY11 5XW
Scotland

Please send me the latest registered version of Kith and Kin at £24

Overseas customers please add £2 to cover shipping and pay in pounds Sterling only (notes 
or UK funds drawn on a UK bank).

I enclose a cheque/PO/cash for £_______ payable to SpanSoft.

Name Mr/Mrs/Miss/Ms_____________________________________

Address _______________________________________________
_______________________________________________
_______________________________________________
_______________________________________________

Postcode ____________________
Country _______________________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
If you require a different size please specify ____________________

Prices correct at July 1994 for V2.03 but registration for later releases may be subject to price increases.



Credit Card Order - Kith and Kin
Please print this order using Print Topic and mail to:
 S & N Enterprises

5 Polden Close
FARNBOROUGH
Hampshire      GU14 9HN

or phone with your credit card details:
(0252) 510486

Please send me the latest registered version of Kith and Kin at £24
Add £2 shipping & handling (UK only).

Please charge my credit card (Visa/Access) with £26 pounds Sterling.

Name Mr/Mrs/Miss/Ms_________________________________________

Address ___________________________________________________
___________________________________________________
___________________________________________________
___________________________________________________

Postcode ________________________
(Note name and address above must match those of your credit card)

Card number
___________________________________________________

Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
If you require a different size please specify ____________________

Prices correct at July 1994 for V2.03 but registration for later releases may be subject to price increases.



Credit Card Order - Kith and Kin
Please print this order using Print Topic and mail to:
 S & N Enterprises

5 Polden Close
FARNBOROUGH
Hampshire      GU14 9HN
UK

or phone with your credit card details:
+44 252 510486

Please send me the latest registered version of Kith and Kin at £24
Add £5 shipping & handling (outside the UK).

Please charge my credit card (Visa/MasterCard) with £29 pounds Sterling.

Name Mr/Mrs/Miss/Ms_________________________________________

Address ___________________________________________________
___________________________________________________
___________________________________________________
___________________________________________________

Postcode ________________________
Country ___________________________________________________
(Note name and address above must match those of your credit card)

Card number
___________________________________________________

Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
If you require a different size please specify ____________________

Prices correct at July 1994 for V2.03 but registration for later releases may be subject to price increases.



Credit Card Order - Kith and Kin
Please print this order using Print Topic and mail to:

Public (software) Library
PO Box 35705
Houston
TX 77235-5705
USA

or FAX this form to:
713-524-6398 (for orders only)

or phone with your credit card details:
800-242-4775 or 713-524-6394 (all numbers for orders only)

PsL product number: #11172
Please send me the latest registered version of Kith and Kin at $36
Add $4 shipping & handling.

Please charge my credit card (Visa/MasterCard/Amex/Discover) with $40 US.

Name Mr/Mrs/Miss/Ms_________________________________________

Address ___________________________________________________
___________________________________________________
___________________________________________________
___________________________________________________

Zipcode ________________________
Country ___________________________________________________
(Note name and address above must match those of your credit card)

Card number
___________________________________________________

Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
If you require a different size please specify ____________________
Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, PsL will notify us 
the day of your order and we will ship the product direct. Please allow two weeks for delivery. Prices correct at July 1994 for V2.03 
but registration for later releases may be subject to price increases.



Order - Kith and Kin
Please print this order using Print Topic and mail to:

Budgetware
PO Box 496
Newtown NSW 2042
Australia

or FAX this form with your credit card details to:
(02) 516-4236

or phone with your credit card details:
(02) 519-4233

Please send me the latest registered version of Kith and Kin at $53
Add $6 shipping & handling.

I enclose a cheque / money order for $59 Australian payable to Budgetware.
Please charge my credit card (Visa/MasterCard) with $59 Australian.
(delete as appropriate)

Name Mr/Mrs/Miss/Ms_________________________________________

Address ___________________________________________________
___________________________________________________
___________________________________________________
___________________________________________________

Postcode ________________________
Country ___________________________________________________
(Note: if paying by credit card, name and address above must match those of your card)

Card number
___________________________________________________

Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
If you require a different size please specify ____________________
Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, Budgetware will 
notify us the day of your order and we will ship the product direct. Please allow two weeks for delivery. Prices correct at July 1994 for
V2.03 but registration for later releases may be subject to price increases.



Order - Kith and Kin
Please print this order using Print Topic and mail to:

Share Warehouse New Zealand Limited
PO Box 13-489
Johnsonville
Wellington 6004
New Zealand

or FAX this form with your credit card details to:
(04) 447-3535

or phone with your credit card details:
(04) 447-3535

Please send me the latest registered version of Kith and Kin at $63.
Add $6 shipping & handling.

I enclose a cheque / money order for $69 NZ payable to Share Warehouse New Zealand 
Ltd.
Please charge my credit card (Visa/MasterCard/Bankcard/Diners/Amex) with $69 NZ.
(delete as appropriate)

Name Mr/Mrs/Miss/Ms_________________________________________

Address ___________________________________________________
___________________________________________________
___________________________________________________
___________________________________________________

Postcode ________________________
Country ___________________________________________________
(Note: if paying by credit card, name and address above must match those of your card)

Card number
___________________________________________________

Expiry date __________________

Signature _____________________________________

Your software will be sent on 1.44Mb 3.5" (HD) floppy disk.
If you require a different size please specify ____________________
Any questions about the status of shipment of order, refunds, registration options, product details, technical support, volume 
discounts, dealer pricing, site licenses, etc, must be directed to SpanSoft. To ensure that you get the latest version, Share 
Warehouse will notify us the day of your order and we will ship the product direct. Please allow two weeks for delivery. Prices correct 
at July 1994 for V2.03 but registration for later releases may be subject to price increases.



Terms of use
TRIAL USE LICENCE

Kith and Kin is NOT freeware or public domain software, it is shareware.    This software, 
associated on-line help and accompanying documentation are copyright © SpanSoft 1993, 1994 
and are protected by international copyright laws. BWCC.DLL is copyright © Borland International
1991.

SpanSoft grants you a limited licence to try out this software on your own system, in your own 
working environment for a limited period of 30 days. If you decide that the software is suitable for
your needs and you wish to continue using it after this time, you must become a registered user 
and pay the appropriate registration fee to SpanSoft. This simply means that you are allowed to 
defer payment for the software until after you have decided that you want it. If, after 30 days, 
you decide that you do not wish to continue using this program you must delete it from your 
system.

You are free (and encouraged) to copy and distribute this version of the software to others on 
condition that you include all the files on your distribution disk and that you adhere to the terms 
of the limited distribution licence.

You may not use, copy, rent, lease, sell, modify, decompile, disassemble, otherwise reverse 
engineer, or transfer the licensed program except as provided in this agreement.    Any such 
unauthorised use shall result in immediate and automatic termination of this licence. All rights 
not expressly granted here are reserved by SpanSoft.

By using this software you are agreeing to the terms of this licence. If you do not agree to these 
conditions, delete this software from your computer.

LIMITED DISTRIBUTION LICENCE

You may distribute this version of Kith and Kin, completely unaltered and including all the files (as
listed below), without further permission on condition that:

    1) You identify it as shareware.
    2) You leave all intellectual property (copyright) notices in place.
    3) SpanSoft does not request that you stop distribution.

To distribute in modified form, you must consult the appropriate data record in the included 
VENDINFO.DIZ file, which is hereby incorporated by reference. Any distribution satisfying all the 
distribution requirements expressed in that data record is hereby authorised.

Permission to distribute the Kith and Kin package is not transferable, assignable, saleable, or 
franchisable.    Each person or organisation wishing to distribute the package must independently 
satisfy the terms of this limited distribution licence.

SpanSoft may revoke any permissions granted here, by notifying you in writing.    All rights not 
expressly granted here are reserved by SpanSoft.

Complete file list:
KITHKIN.EXE Kith and Kin program
KITHKIN.HLP Kith and Kin help file
KITHKIN.OPT Kith and Kin options file
BWCC.DLL Borland custom class DLL
SAMPLE.TRE Sample tree file
CATALOG.HLP SpanSoft product catalogue
FILE_ID.DIZ BBS file description



VENDINFO.DIZ Vendor / BBS information
README.TXT User information
VENDOR.TXT Vendor information

LIMITED WARRANTY

Please read carefully.

THIS SOFTWARE IS PROVIDED FOR EVALUATION ONLY, ON AN "AS IS" BASIS.

SPANSOFT DISCLAIMS ALL WARRANTIES RELATING TO THIS SOFTWARE, WHETHER EXPRESSED OR
IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE. NEITHER SPANSOFT NOR ANYONE ELSE WHO HAS BEEN 
INVOLVED IN THE CREATION, PRODUCTION, OR DELIVERY OF THIS SOFTWARE SHALL BE LIABLE 
FOR ANY INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES ARISING OUT OF THE USE OR 
INABILITY TO USE SUCH SOFTWARE, EVEN IF SPANSOFT HAS BEEN ADVISED OF THE POSSIBILITY 
OF SUCH DAMAGES OR CLAIMS.

THE PERSON USING THIS SOFTWARE BEARS ALL RISKS AS TO THE QUALITY AND PERFORMANCE 
OF THE SOFTWARE. ALTHOUGH THIS SOFTWARE HAS BEEN EXTENSIVELY TESTED, IT IS YOUR (THE
USER'S) RESPONSIBILITY TO DETERMINE IF IT WILL WORK RELIABLY ON YOUR EQUIPMENT AND IN 
YOUR COMPUTING ENVIRONMENT.

Remember. Always keep up-to-date backup copies of all your data files.



Database limits
You can have up to 16383 people and families combined.
The size of the tree area is approx. 200 families wide by 350 high.
The maximum number of characters which can be held in each person or family notes is 9500.
The Descendant and Ancestral Tree Prints will handle up to 80 generations in a single printout.
Ultimately, the total amount of tree data will depend on the amount of available memory (RAM) 
in your PC. However, a 4Mb PC with a 6Mb swapfile (the standard setup) should be sufficient to 
hold the maximum tree size, depending on the size and number of notes, objects and other 
Windows applications running.
To some extent the speed of your PC will govern the usability of the software with large amounts 
of data.



Known incompatibilities
OBJECTS
Some applications which produce objects for embedding or linking, do not provide a picture 
image of the object. In these cases Kith and Kin will not be able to embed or link the object to a 
person or family in the normal way. You can, however, use the Windows Object Packager to 
associate an icon with the object. This will then allow Kith and Kin to use the object as normal. 
See the on-line help in Object Packager or your Windows documentation for further details.

GEDCOM
Kith and Kin has problems importing GEDCOM files created by Pedigree. Pedigree exports an 
older style of GEDCOM file which has no space character between the cross-reference ids and 
certain tags. You can overcome this problem by editing the GEDCOM file directly using NOTEPAD, 
a word processor or other text editor. Search for the text "@INDI" and "@FAM" and replace them 
with "@ INDI" and "@ FAM" respectively throughout the entire GEDCOM file (do not enter the 
quote marks). Save the file and you will now be able to import it into Kith and Kin successfully.




